Call us — 0113 322 3083
Mon–Fri · 9am–5:30pm · No fix, no fee
Start a free diagnostic →
Device · SAN

SAN recovery, failed LUN to live volume.

A SAN has a high number of disks. This SAN can also contain multiple RAID groups as well as layers of logical units (LUNs) and virtualisation. When these devices fail they will normally still contain all the data. However, this data may be buried under the failed abstraction. We will help you recover your storage area networks (SANs) regardless of whether you have experienced loss of more disks than allowed by the redundancy level. As well as a single controller failure, we will assist with recovery of your SAN should you experience a LUN going offline or becoming corrupted. This type of job is considered to be very complex and requires one of our highly trained engineers who specialises in rebuilding large multi-disk arrays completely from images. Irrespective of whether you have an enterprise level device such as a Dell EMC, HPE, NetApp or consumer level products including QNAP/Synology SANs, the diagnosis is always complimentary; however, in most cases you will only incur costs if your data is recovered.

In-house, never outsourced
Only pay if we recover your data, on most jobs
Drop off in Leeds, or post it
// the golden rule

Don’t re-initialise it.

When you re-initialise a SAN (or force a LUN back online) or rebuild to degraded disks you may write over recoverable data. Please shut it down so we can make an image of all disks prior to making any changes.

Stop rebuilding
until it’s imaged
Label the bays
before pulling disks
Send every disk
even the “dead” one
Free look
before any cost
// how a SAN fails

Layers on layers.

Most times when your SAN fails, you have not lost just one disk. Below each LUN sits one or more RAID groups. If another disk in a group goes bad; if the controller fails; or if you have a corrupt LUN map, then volumes will go offline even though the data remains intact. In some cases, it is the metadata (the pool or LUN configuration) which was damaged by either a power event or firmware upgrade, and therefore your healthy disks are now being displayed with no volume. All layers need to be rebuilt in sequence, and using your SAN’s “repair” or “re-initialise” utilities is not the correct method for doing this.

// how we recover it

Every disk imaged, the stack rebuilt.

We copy each individual disk in the SAN (storage area network), then rebuild the entire disk system piece-by-piece using those copies. First we reconstruct all of the RAID groups that underlie the pool and LUNs (logical unit numbers). Next, we build back up to the pool and LUN structures. Then finally we restore the file systems and VMs (virtual machines) within them. The actual work of this task is figuring out how the original disks were ordered, striped and mapped to which LUNs, and to do so from a set of images is a way for us to never hurt anything we attempt to fix. Your disks leave exactly as they arrived, and you’ll have your exact volumes restored from the rebuilt stack.

// every make

Dell EMC, HPE, NetApp and more.

We recover Dell EMC, HPE, NetApp, IBM, Infortrend and QNAP/Synology SAN units that are in a pooled configuration or RAID 5, 6, or 10, also across iSCSI and Fibre Channel. Label each disk by enclosure and slot position. Send the controllers (or head unit) where you can; just as important as sending the disks is the LUN/pool configuration.

// questions

Asked often, answered straight.

Typically, yes. Offline LUNs are almost always metadata or mapping issues rather than lost data; the hard drives will still have all of your information on them. We image each drive and then build the RAID groups, pool and LUN layout off the hardware to get the volume back up again. The biggest risk is forcing a LUN online first.

Often not. With two failing disks you typically do not lose both disks completely; therefore we generally can create an image with sufficient good data to calculate the parity for a rebuild. While this is a lot tougher than one disk loss, it is far from hopeless: send us all of your disks (including those that are marked as failed).

Please send us your disks with labels on them for the enclosure and slot they reside in as well as the controllers or head unit if possible. The disks are where the actual data resides. However, the configuration of the controller will tell us how the LUNs and pools were assigned to each other. This is critical in order to correctly assemble the entire stack.

Once you have a quote, please drop off your SAN at our office located at The Pinnacle, Leeds (we do not require an appointment). Alternatively, you may post it to us via a fully insured method. We will walk you through the process of properly preparing your enclosures and disks for shipping. Regardless of which option you choose, everything is handled in-house by our engineers.

Usually, yes, if it has been preserved. All underlying disks are read-only imaged and the storage layout is constructed out of those images and then the LUN or datastore is virtually rebuilt prior to restoring. The problem is remedial writes to the live array (the original), so freeze any changes, and contact us first.

// what it costs

Pricing, up front.

A complimentary diagnosis will be given first, followed by a fixed quotation in writing prior to any repairs taking place, with no fees for most jobs if the data cannot be recovered. SAN recovery quotes will be generated after diagnosis because there are many variables that affect cost such as how many disks you have, what kind of RAID configuration you are running, etc. However the costs will be fixed in writing prior to doing any billable work. Once you receive your quote simply bring your unit to our offices located at The Pinnacle in Leeds (no need for an appointment) or post it to us fully insured from anywhere in Yorkshire. Either way, it’s handled in-house by our own engineers and never outsourced.

// near me

SAN data recovery near me? You just did.

No one searches for “SAN data recovery near me” when things are going right; that’s just a sign of a LUN being offline, a datastore gone, and people breathing down your neck. The road to all successful recoveries is always the same: take an image of everything read-only, recreate against the original layout, then restore from those images.

Once you receive a quote for your project, bring your device to the counter at The Pinnacle on Albion Street. You can visit us Monday to Friday between 9am and 5:30pm (no appointments necessary). Alternatively, send your device by insured post. Our data recovery UK services cover all areas of the United Kingdom under the same conditions: free diagnostic, fixed written quote and no charge on most projects unless we recover your data.

// SAN offline?

LUN down or array degraded? Bring us every disk.

The diagnosis will be at no cost; we will provide you with a fixed written price quote for each job; and most jobs will have absolutely no charge unless your data is restored. Do not reinitialise or bring a LUN online after you have identified the problem; simply shut it down and then send the disks to us after you have received a quote from us.

0113 322 3083