Call us — 0113 322 3083
Mon–Fri · 9am–5:30pm · No fix, no fee
Start a free diagnostic →
Device · databases

Database recovery, corrupt file to clean restore.

Databases may fail without a disk dying, due to issues such as (i) corruption of a SQL or Exchange file after an unexpected power cut; (ii) a database that fails to mount and appears “suspect” for unknown reasons; (iii) tables which return errors on a query or report; or (iv) a collection of files lost because the physical hard drive failed. Our services will diagnose and attempt to recover damaged databases using a file-level approach. If a failure of the underlying storage occurs, we will initially attempt to recover the storage before attempting to recover the database. Regardless of whether it be Microsoft SQL Server database recovery, Microsoft Exchange recovery, MySQL recovery, or Access recovery, our initial diagnosis regarding potential recovery options is always complimentary. In most instances you will only incur costs if we recover your data.

In-house, never outsourced
Only pay if we recover your data, on most jobs
Drop off in Leeds, or post it
// the golden rule

Stop running repair.

Any repeated repair, restore, or “emergency mode” operations performed on an already corrupted database will likely write over the good (intact) pages in the database. Take a copy of the files as they are, and we’ll be working off that copy as we go along.

Stop writing
no repair, no restore
Keep the original
work from a copy
Send the whole set
disks and config
Free look
before any cost
// how databases fail

Database recovery without a dead disk.

Most database-related emergencies are related to logic rather than physical issues. A power loss or system failure during a write operation results in either a logically damaged SQL MDF or Exchange EDB file; the file is still physically present but has been flagged by the respective database engine as suspect and therefore cannot be mounted. In some cases, this occurs due to a missing or truncated transaction log. Other times, this happens when a single page becomes corrupted due to a hardware failure. Some examples include when an administrator deletes a record, or when a migration is improperly completed. If the drive itself has failed, the database files come back only once the storage has been recovered. In all scenarios described above, the default built-in option to “repair with data loss” will often remove the very records you needed.

// how we recover it

Copied first, repaired at page level.

We always restore using copies of the database (and therefore, we do not restore using the original database). Then, we fix up the internal structures (the way the pages link together), extract data from each table and mailbox separately if the engine cannot read the file, and match up the logs as needed, depending on which survived. If the storage has failed, once it has been recovered (i.e., the disk(s) or array have been imaged and recovered), then the database files will be copied from the recovered volume for a full restore. The aim is always a clean restore of your actual records, not a repaired but lossy shell.

// every engine

Database recovery services: SQL Server, Exchange, MySQL.

We handle MS SQL Server (MDF/LDF) and Exchange (EDB) as well as MySQL/MariaDB, PostgreSQL, Oracle and Access databases, and also the file share locations and backups surrounding them. Please forward all the database and associated log files and, if the failure relates to your disk(s), the disk(s) as well. For a server/RAID environment please remove the disks from the server or RAID enclosure and send us these disks so that we can have access to the source.

// questions

Asked often, answered straight.

Usually, yes. Normally, “suspect” indicates an integrity issue in the database due to some sort of failure, but does not indicate data has been lost. The database remains intact under the bad structure. Therefore, we will make a copy of your database and logs, attempt to rebuild the structure, or pull individual tables so that you may perform a full restore without having to run a potentially lossy recovery on your data.

Until you have made a copy of your database, we would recommend not running a repair. SQL’s repair option with data loss or Exchange’s hard repair options could potentially delete the exact records you are looking for. Make copies of both your database and log files as they currently exist, and allow us to work off those copies.

Yes, this is a two-step process: first, we will create an image of the failed disk or disk array to ensure all data possible can be extracted; next, once we have the recovered images of the disk(s), we will begin to identify, recover and repair the corrupted database files. Please send us the drive, or for a server the disks removed from it (along with the details of the database).

Often, yes. If the engine will not load the file at all, extracting individual tables or even an entire Exchange mailbox directly from the copy of the database frequently provides enough data for your needs.

Frequently, and safer than using repair tools to run in-place against the live file. First, the database is copied; secondly, repair work is performed by page-level repairs from the copy of the database; thus, tables that would otherwise be lost by the built-in tools are recovered. Never, ever use REPAIR_ALLOW_DATA_LOSS against the original; the name tells the whole story.

// what it costs

Pricing, up front.

A free diagnosis before we even start work, a written quote with a fixed price based on that diagnosis, and no fee for most jobs if none of your data is recovered. Database repair is usually a fixed price based on the type of file damage we see. When we need to recover a drive prior to database repair, the cost will be provided as a separate quotation following our free diagnostic review. Once you have a quotation, simply take your device to our office at The Pinnacle in Leeds (you do not need an appointment) or send it to us fully insured through the postal service from anywhere in Yorkshire. Regardless of which method you choose, all services are performed by our team of engineers in-house and never outsourced.

// near me

Database recovery near me? You just found it.

Database recovery near me is a different type of search than the other searches on this website. In many cases the hard drive itself is okay but the problem exists with the database records within the MDF, EDB or MyISAM files. This requires page-level repairs. These repairs are made using an exact duplicate of the original database, and will never be done directly on the active database.

Once you receive a quote for your project, bring your device to the counter at The Pinnacle on Albion Street. You can visit us Monday to Friday between 9am and 5:30pm (no appointments necessary). Alternatively, send your device by insured post. Our data recovery UK services cover all areas of the United Kingdom under the same conditions: free diagnostic, fixed written quote and no charge on most projects unless we recover your data.

// database down?

Suspect, corrupt or lost? We’ll get a clean restore.

We offer a free diagnostic check and a fixed written quote for all work we do (with no charge on most jobs unless your information is recovered), so don’t keep trying to fix it. Make a backup of what’s there now; when we give you a quote, send the files to us.

0113 322 3083