RAID provides redundancy, but not necessarily “immortality”, and when an array goes down, it often goes down badly; the items responsible for protecting you are the items that have stopped working. We reassemble failed RAID data recovery services projects at all levels: whether it is a RAID 0 that has lost one member, a RAID 5 that lost a second drive while rebuilding, a RAID 6 that was damaged due to a controller malfunction, or a RAID 10 with incorrect drives removed. Whether it’s a NAS, a server or a bare array, diagnosis is always free and in most cases, you only pay if we can successfully recover your files.
The most frequent way in which good data is lost forever is when you force a rebuild onto a degraded array. Please stop! Label each disk so we know which one is next in line, and label the order of the disks as well. Then please call us. We will image everything off prior to any write-back activity.
A RAID’s most common disaster is a second failure occurring after an unnoticed first failure. Typically one of the disks in a RAID 5 configuration fails unnoticed, and the array continues running. The second disk may fail weeks later, at which point the RAID array is no longer redundant and goes offline. In addition, if either a controller card or motherboard fails, the RAID’s metadata can become corrupted, or a rebuild started with the disks in the wrong order can overwrite the parity. Finally, RAID 0 does not have redundancy; therefore the death of a single drive results in the complete failure of that volume. None of the above situations can be corrected through a rebuild initiated from the controller; that is usually what finishes the job.
The physical drives are never handled while being restored. Instead, each member drive of the RAID is copied as an image onto our own servers. Then using these images we manually determine the RAID configuration (disk layout, striping size, parity rotation & offsets). Using this information we then reassemble the array virtually and then pull your data off of it. At no time do we alter the original hardware; because we use images to rebuild your RAID instead of actual hardware, if there’s an error during rebuilding of your RAID there will be no loss or cost: we simply retry.
We support all configurations for RAID such as RAID 0, RAID 1, RAID 5, RAID 6, RAID 10, RAID with nesting and hybrids on a controller, on motherboards, or with software: Dell PERC, HP Smart Array, LSI/Broadcom, Adaptec, SHR on Synology DiskStations, Windows Storage Spaces, and Linux mdadm. Send us the disks from your server or enclosure. Remove each disk from the server or enclosure. Clearly label each disk with the number of the bay it came from.
Yes, very frequently. When a secondary disk fails, it rarely fails entirely at once, so you usually still have enough data on that disk for us to be able to image enough of it so that we are able to recover your parity and build back your array. This will require more effort and time than if it was just a single failed disk; however, this is far from an impossible task: pull out every disk (including those disks marked as bad) from the server or enclosure and ship them all to us.
Yes, a dead controller will leave good hard drives (disks) stranded because they were all controlled by this bad controller. So instead of using a dead controller for RAID recovery we can use the actual disks and build the RAID array ourselves without having to rely on the dead controller. All we need is the disks, taken out of the server or enclosure, in their original order, plus the controller model if your setup is not standard.
No. Rebuilding a RAID array onto an already damaged array or starting a rebuild with the disks out of order is the most common reason for permanent RAID data loss. Shut it down ASAP, and we will create an image of each disk before you write anything back.
Yes. Whether it’s just an array, a NAS or a full server, we will make images of the individual disks and then reassemble the array from those images. For servers, please remove the disks and ship them to us, but be sure to label which disk was originally in what bay. We cannot accept a fully assembled server.
Usually yes, as long as no other actions are forced. The failure of a RAID 5 rebuild can be recovered from an image set for each individual disk in the RAID group; then we solve for the correct RAID group ordering and generate the parity information and create a virtual assembly of your RAID volume. However, if you force another rebuild with the same disks, it will destroy all chance of restoring the RAID.
A complimentary preliminary assessment prior to a written fixed price quotation for any repair work, along with no fee to be charged for most recoveries should the recovery process fail. Quotes for RAID and server recoveries will be given after an initial assessment has been carried out, due to pricing being based upon the number of disks involved and type of disk failure. However, quotes will also include an upfront commitment of a fixed cost in writing prior to commencing any chargeable works. Once a client receives a quote we encourage clients to remove the disks from their respective server or enclosure and drop them at our office in The Pinnacle, Leeds (no appointment needed), or send them fully insured by post from anywhere in Yorkshire. Either way, they’re handled in-house by our own engineers and never outsourced.
An encrypted RAID array is very much a different form of failure than a failed individual disk, and unfortunately a much more frequent occurrence than in years past. Our ransomware data recovery team always treats each RAID in the same safe way: isolating the RAID first, imaging all disks read-only, then recovering using decryptors, snapshots and anything else that was missed by the attacker. We do not pay or negotiate with attackers.
Anyone looking for RAID data recovery near me will typically have just had a rebuild fail, and the most important thing to remember about this web site is that you should never start another rebuild. Remove all member disks from your server or enclosure; once you have a quote, post or deliver all disks (in any order) in their original condition.
Once you have a quote you can walk it into The Pinnacle on Albion Street any weekday (no appointment needed); or post it to us fully insured from anywhere within the country. As part of our UK-wide data recovery service, the terms remain unchanged: diagnosis is always free; price will be fixed in writing; and we won’t charge for most jobs unless we succeed.
It doesn’t cost anything for a diagnosis, there are fixed written quotes, and most jobs are at no charge unless your data comes back. Stop the rebuild, preserve the original order of disks, and then, once you have the quote we provide, send the disks to us; this will protect whatever was recoverable.